Author Topic: Critical! Queue is not enabled in cron. Add following crontab entry: * * * * *  (Read 113 times)

0 Members and 1 Guest are viewing this topic.

Offline andika

  • 151
  • -1
  • Active Participant
  • ****
Hello,

Yesterday I have upgrade VPS size and extend disk using partion tools, all websites from server are fine but it seems like hostbill website have some issues now, I don't know if that's the cause but it came after.

I got this error on admin area : Critical! Queue is not enabled in cron. Add following crontab entry: * * * * * php /home/admin/public_html/mysite.com/queue.php

I already added that line long time ago but I double checked , restarted crond, rebooted server, etc with no result. The strange thing is that automatic terminate/suspend task is affected. When I manually trigger that I get:

Pending auto provisioning tasks:
Attempting to terminate account #3282:  Scheduled
Attempting to terminate account #4097:  Scheduled
Attempting to terminate account #4098:  Scheduled
Attempting to terminate account #4099:  Scheduled
Attempting to terminate account #4100:  Scheduled
Accounts suspended: 0
Accounts terminated: 5
Addons suspended: 0
Addons terminated: 0

When I check the listed accounts, i.e. 3282 the status is supended and today the server should be terminated but it doesn't, instead I get ' delete account task is scheduled' message on right button corner . If I manually trigger terminated nothing happen, the page refresh with the same pop up message. 

Since yesterday all tasks are pending here Extras → System Logs → Task queue log. I also got message  Queue is: Stopped  
I used this command on ssh  php -q /home/admin/public_html/my.site.com/queue.php   with no result

I have updated Hostbill to the last 7.08.2018 version with no result. 

I Just noticed I can't do nothing anymore, deploy new servers, send emails, etc, nothing.

Maybe the automatic task where triggered exactly when I extend the disk and not its stuck somewhere in DB, how to fix my problem because right now I manually have to access SolusVM and terminate each server and change status on hostbill etc. Its a mess..

Thank you !
 
« Last Edit: August 10, 2018, 11:07:36 AM by andika »

Offline andika

  • 151
  • -1
  • Active Participant
  • ****
Any advise on this ?

Offline Fusionhost

  • 247
  • 4
  • Active Participant
  • ****
    • Fusionhost
I think we are having this issue.
fusionhost - www.fusionhost.co.uk
Leading student web host provider utilising SSD cloud platforms

Offline andika

  • 151
  • -1
  • Active Participant
  • ****
I think we are having this issue.

Did you fix it ?

Offline Factor

  • 44
  • 0
  • Active Participant
  • **
  • Welcome to reality wish you could stay longer..
Are you running HB on Cpanel or some other Panel OR are you running HB through the install on a machine all by itself.  I find on Panel servers you have to use -r

if you want to know if the queue is up and running in the background (this is if you are not doing  -r)
ssh and do

ps -ef | grep 'hostbillqueue'

the log is

tail -f /home/were you put /templates_c/hostbillqueue.log

You also might put the full path to PHP
like
/usr/local/bin/php -q /home/YOUR USER/public_html/YOURFolder/queue.php -r


/usr/local/bin/php -q /home/YOUR USER/public_html/YOURFolder/queue.php -h
Help is under -h

HostBill Queue Manager

USAGE:
  # queue.php

OPTIONS:
  -P              Override PID file to use
  -h              Show help
  -l              Override Log file to use
  -v              Increase verbosity level by one
  -x              Maximum seconds for a worker to live
  -Z              Parse command line options and dump config on screen (debug)
  -D              Number of workers for new queues to run at once
  -r              Force queue to run using cron queue handler (without forking/workers)
  --hb_acc_provisioning=NUMBER     Set number of workers for queue: Provisioning (default: 2). 0 to disable workers on this queue.
  --hb_utilities=NUMBER     Set number of workers for queue: Utilities (default: 2). 0 to disable workers on this queue.
  --hb_dom_provisioning=NUMBER     Set number of workers for queue: Domains (default: 2). 0 to disable workers on this queue.
  --hb_mail_queue=NUMBER     Set number of workers for queue: Mailing (default: 3). 0 to disable workers on this queue.


https://hostbill.atlassian.net/wiki/spaces/DOCS/pages/491527/HostBill+Queue+Performance
« Last Edit: March 11, 2019, 08:12:42 PM by bdacus01 »
Thanks,
The Factor