Author Topic: Upgrade error  (Read 55 times)

0 Members and 1 Guest are viewing this topic.

Offline dhairya

  • 3
  • 0
  • New Member
  • *
Upgrade error
« on: September 15, 2017, 10:09:29 AM »
Hi,

 I have tried upgrading my hostbill to the latest version and ended up with an error and a broken client area. Please help, error details are as follows:

HostBill Upgrade Failed
Something went wrong during upgrade process, following error occured during database operations:
Following error :SQLSTATE[HY000]: General error: 1553 Cannot drop index 'order_id': needed in a foreign key constraint
occured during database update to version 2016-07-17.sql please load your database backup to ensure that your installation is stable, and/or contact HostBill support
Failed on query: ALTER TABLE `hb_fraud_output` ADD COLUMN `type` ENUM('Order','Client') NOT NULL DEFAULT 'Order' AFTER `id`, CHANGE COLUMN `order_id` `rel_id` INT(11) NOT NULL AFTER `type`, DROP INDEX `order_id`, ADD INDEX `type_rel_id` (`type`, `rel_id`);
« Last Edit: September 15, 2017, 10:26:55 AM by dhairya »

Offline dhairya

  • 3
  • 0
  • New Member
  • *
Re: Upgrae error
« Reply #1 on: September 15, 2017, 10:18:33 AM »
After manually removing the foreign key from db, the upgrade process was completed and then I tried to login and then ended up with this error.

Uh oh! Something went wrong ...
Exception: Class SupportFields does not exist IN /public_html/manage/hbf/core/class.hbloader.php(397), stack trace:
#0 /public_html/manage/hbf/core/class.hbloader.php(397): ReflectionClass->__construct('SupportFields')
#1 /public_html/manage/hbf/core/class.hbloader.php(298): HBLoader::_load('Other/SupportFi...', 'Other', false, false)
#2 /public_html/manage/hbf/core/class.autoload.php(248): HBLoader::LoadModule('Other/SupportFi...', Array)
#3 /public_html/manage/hbf/core/class.autoload.php(133): AutoLoad->autoloadDB('supportfields', 'class.supportfi...')
#4 [internal function]: AutoLoad::loader('SupportFields')
#5 /public_html/manage/hbf/core/class.hbloader.php(397): spl_autoload_call('SupportFields')
#6 /public_html/manage/hbf/core/class.hbloader.php(298): HBLoader::_load('Other/SupportFi...', 'Other', true, true)
#7 /public_html/manage/hbf/core/class.modulefactory.php(153): HBLoader::LoadModule('Other/SupportFi...')
#8 /public_html/manage/hbf/components/template/class.template.php(257): ModuleFactory->getTemplatedAddons('admin', true)
#9 /public_html/manage/hbf/components/template/class.template.php(423): Template->preAssign()
#10 /public_html/manage/hbf/components/template/class.template.php(383): Template->display('header.tpl', NULL, '1c7caf30590504c...')
#11 /public_html/manage/hbf/core/class.controller.php(179): Template->show()
#12 /public_html/manage/hbf/core/types/class.admin_frontcontroller.php(126): Controller::render(2)
#13 /public_html/manage/hbf/core/class.frontcontroller.php(144): Admin_FrontController->dispatch(Object(RequestHandler))
#14 /public_html/manage/hbf/core/class.frontcontroller.php(124): FrontController->handleRequest('admin', Array)
#15 /public_html/manage/internal/index.php(24): FrontController::init('admin')
#16 {main}

Offline dhairya

  • 3
  • 0
  • New Member
  • *
Re: Upgrade error
« Reply #2 on: September 17, 2017, 04:56:33 AM »
I fixed the issue by disabling this  extension in the db. Though there is a new issue,  Cron job doesnt seems to work, tried everything but it just doesnt work. Any clue what is wrong with the setup?

Your CRON job for HostBill doesn't seem to be working, please verify
To enable the automation features to run, make sure you set up a cron job to run every 5min.

Tried with and withough cpanel interface (adding direct with crontab -e) but nothing worked.

Offline VPSKing

  • 40
  • 0
  • Active Participant
  • **
Re: Upgrade error
« Reply #3 on: November 21, 2017, 04:07:08 AM »
I have exactly same issue.
What to disable to make it work again?


I fixed the issue by disabling this  extension in the db. Though there is a new issue,  Cron job doesnt seems to work, tried everything but it just doesnt work. Any clue what is wrong with the setup?

Your CRON job for HostBill doesn't seem to be working, please verify
To enable the automation features to run, make sure you set up a cron job to run every 5min.

Tried with and withough cpanel interface (adding direct with crontab -e) but nothing worked.

Offline VPSKing

  • 40
  • 0
  • Active Participant
  • **
Re: Upgrade error
« Reply #4 on: November 21, 2017, 06:27:41 AM »
I have revert it back. disabled support field and it worked to me.